EBS pro causing the application to run out of memory

Home Forums Easy Bootstrap Shortcodes PRO EBS pro causing the application to run out of memory

Tagged: , ,

This topic contains 3 replies, has 2 voices, and was last updated by  Emily Barwick 6 days, 14 hours ago.

  • Author
    Posts
  • #10482

    Emily Barwick
    Participant

    Hello,

    I’ve had this issue for a few months. My site keeps overloading things and my hosting says that “the plugin easy-bootstrap-shortcode-pro.off was still active and causing the application to run out of memory.”

    I purchased the Pro and was immediately told that it was causing issues. But I have a lot of existing short codes that break when it’s off.

    They also said the site’s not caching and that “You’ll want to review the following plugins as they appear to be creating cookies:”

    EBS was listed a lot as follows. I’m not sure what to do at this point. If the plugin is on, the site overloads. If it’s off, all the shortcodes all over my site break and things look a hot mess.

    Any advice on what to do would be appreciated. Here is the stuff they sent about the plugins making cookies:

    ./wp-content/plugins/easy-bootstrap-shortcodes/styles/ebs-dstyle.php:if(!session_id()) @session_start();
    ./wp-content/plugins/easy-bootstrap-shortcodes/styles/ebs_dynamic_css.php:if(!session_id()) @session_start();
    ./wp-content/plugins/easy-bootstrap-shortcodes/shortcode/slider/plugin_shortcode.php: ebs_session_start();
    ./wp-content/plugins/easy-bootstrap-shortcodes/shortcode/slider/plugin_shortcode.php: ebs_session_start();
    ./wp-content/plugins/easy-bootstrap-shortcodes/shortcode/servicebox/plugin_shortcode.php:ebs_session_start();
    ./wp-content/plugins/easy-bootstrap-shortcodes/shortcode/servicebox/plugin_shortcode.php: ebs_session_start();
    ./wp-content/plugins/easy-bootstrap-shortcodes/osc_bootstrap_shortcode.php: ebs_session_start();
    ./wp-content/plugins/easy-bootstrap-shortcodes/osc_bootstrap_shortcode.php: ebs_session_start();
    ./wp-content/plugins/easy-bootstrap-shortcodes/osc_bootstrap_shortcode.php: function ebs_session_start() {
    ./wp-content/plugins/easy-bootstrap-shortcodes/osc_bootstrap_shortcode.php: @session_start();

    ./wp-content/plugins/easy-bootstrap-shortcode-pro.off/osc_bootstrap_shortcode.php: function ebs_session_start() {
    ./wp-content/plugins/easy-bootstrap-shortcode-pro.off/osc_bootstrap_shortcode.php: @session_start();
    ./wp-content/plugins/easy-bootstrap-shortcode-pro.off/assets/styles/ebsp-dstyle.php:session_start();
    ./wp-content/plugins/easy-bootstrap-shortcode-pro.off/assets/styles/ebs_dynamic_css.php: session_start();
    ./wp-content/plugins/easy-bootstrap-shortcode-pro.off/assets/js/carousel-dynamic.php: session_start();
    ./wp-content/plugins/easy-bootstrap-shortcode-pro.off/lib/ebs_ajax.php: session_start();
    ./wp-content/plugins/easy-bootstrap-shortcode-pro.off/lib/ebs_ajax.php: session_start();

  • #10483

    Emily Barwick
    Participant

    Just heard back more from my hosting provider. They’ve said:

    “Unfortunately the plugin’s [EBS + EBS Pro] issues with hitting our cache have been present since at least before September as we notified you of the resource usage in #97099.

    We can try to enable the easy-bootstrap-shortcode-pro and then disable all of the cookies using a plugin, but that would be a band-aid fix and may also have a negative effect on some of the functionality of your site. It’s possible that the PRO version of the plugin introduced these issues; I’d recommend contacting the plugin developers if they have a patch or solution that doesn’t require the PHP sessions from being initiated.”

    I hope this helps with describing the issue.

  • #10484

    osCitas Themes
    Keymaster

    Hi Emily Barwick,

    Thanks for contacting us. We will check the issue and will provide the update soon.

    Regards,

    Support Team

  • #10510

    Emily Barwick
    Participant

    Hi, is there any movement on this? I’m still having severe issues with the plugin.

You must be logged in to reply to this topic.